Benutzer-Werkzeuge

Webseiten-Werkzeuge


public:wettbewerbe:getconnected:blubb

Get Connected To ICPC Contest Information

Domjudge

Login unter: http://domjudge.iti.uni-karlsruhe.de/team/

Domjudge Meldungen:

Ausgabe Bedeutung
Accepted korrekte Antwort
Presentation Error richtige Antwort, aber falsch formatiert (Leerzeichen, Leerzeilen…)
Wrong Answer falsche Antwort
Compile Time Error Compile Fehler (inklusive Warnings)
Runtime Error Programmabsturz
Program Size Exceeded zu viel Quellcode
Output Limit Exceeded zu viel Ausgabe
Invalid Function Stacküberlauf oder verbotener Systemaufruf
Invalid Submission Webinterface fehlbedient oder Einsendung disqualifiziert

Compiler Einstellungen

Unsere Compiler Einstellungen sind:

  • GCC: gcc/g++ -O2 -Wall -static
  • Java: java -Xmx300m -Xms64m $MAINCLASS

Programm Testen

g++ -O2 -Wall -static your_program.cpp

./a.out < sample_input > your_output

diff your_output sample_output

Beispielprogramme

Quellcode in C

#include <stdio.h>
 
const int MAX_ARRAY_SIZE = 1000;·
 
// Arrays global anlegen um Stapeluberlaeufe zu vermeiden.
int array[MAX_ARRAY_SIZE];
int array_size;
 
int main(){
    // Mit scanf kann man einzelne ints einlesen.
    scanf("%d", &array_size);
    for(int i=0; i<array_size; ++i){
        // Liesst das naechste int ein (und ueberspringt dabei
        // alle Leerzeichen, Tabs und Zeilenumbrueche). Das int
        // wir an die i-te Stelle des Arrays gespeichert.
        scanf("%d", array + i);
    }
 
    // Nun verwenden wir die eingelesenen Daten
    int sum = 0;
    for(int i=0; i<array_size; ++i){
        sum += array[i];
    }
 
    // Mit printf kann man ints und Zeilenumbrueche ausgeben.
    printf("%d\n", sum);
 
    return 0;
}

Quellcode in C++

#include <iostream>
 
using namespace std;
 
const int MAX_ARRAY_SIZE = 1000;·
 
// Arrays global anlegen um Stapeluberlaeufe zu vermeiden.
int array[MAX_ARRAY_SIZE];
int array_size;
 
int main(){
    // Mit cin kann man einzelne ints einlesen.
    cin >> array_size;
    for(int i=0; i<array_size; ++i){
        // Liesst das naechste int ein (und ueberspringt dabei
        // alle Leerzeichen, Tabs und Zeilenumbrueche). Das int
        // wir an die i-te Stelle des Arrays gespeichert.
        cin >> array[i];
    }
 
    // Nun verwenden wir die eingelesenen Daten
    int sum = 0;
    for(int i=0; i<array_size; ++i){
        sum += array[i];
    }
 
    // Mit cout kann man ints und Zeilenumbrueche (endl) ausgeben.
    cout << sum << endl;
 
    return 0;
}

Quellcode in Java

import java.util.Scanner;
 
class Main {
    public static void main(String[] args) {
        Scanner s = new Scanner(System.in);
 
        int array_size = s.nextInt();
        int[] array = new int[array_size];
        for(int i=0; i<array_size; ++i){
            array[i] = s.nextInt();
        }
 
        int sum = 0;
        for(int i=0; i<array_size; ++i){
            sum += array[i];
        }
 
        System.out.println(sum);
    }
}
public/wettbewerbe/getconnected/blubb.txt · Zuletzt geändert: 2011-01-28 12:52 von moritz